Calc. Cualificación do alumnado

Partimos da seguinte táboa (descargar aquí)

1. O primeiro que se calcula é a media aritmética das notas.

Opción a. Poderiamos introducir a seguinte fórmula, e funcionaría

=(B2+C2+D2+E2+F2)/5

Opción b. Tamén poderiamos introducir a seguinte para non ter que seleccionar todas as celas.

=MEDIA(B2:F2)

Sen embargo se non existen notas, a folla de cálculo imprimiría o seguinte erro: #DIV/0! na columna Media

Para evitar que a folla de cálculo imprima ese erro, podemos engadir un control de erros, de maneira que se atopa un erro non impriman nada e que calcule a media en caso contrario. En caso de que non exista nota non presupón un 0.

=SEÉERRO(MEDIA(B2:F2);"")

 

2. Para calcular a Nota, pódese empregar a seguinte expresión:

=SEÉERRO(SE(G2="";"";SE(G2>=9;"SOBRESALIENTE";SE(G2>=7;"NOTABLE";SE(G2>=6;"BEN";SE(G2>=5;"SUFICIENTE";SE(G2>=0;"INSUFICIENTE"))))));"")

 

3. Co obxectivo de evitar erros á hora de introducir datos nas diferentes celas, podemos seleccionalas e ir a Datos > Validación

E ábrese unha pantalla, e procedemos a introducir os datos de validación e de alerta:

 

 

4. Co obxectivo de non equivocarnos de columna á hora de introducir as notas, resulta moi práctico a opción de conxelar a primeira columna:
Ver > Conxelar celas > Conxelar a primeira columna. Seguidamente desprazamos o cursor á dereita ata que situar a columna de traballo pegada á primeira columna, a dos nomes.

 

5. Por último establecemos un formato condicional na columna nota. Imaxinemos que queremos acadar o seguinte:

a. Selecionar as celas das notas e pinchar en Formato > Formato condicional > Condición...

b. Establecemos a primeira condición. Se a cela está sen datos engadir un fondo vermello

c A segunda condición. Se a cela ten o valor INSUFICIENTE, tamén se debe de engadir un fondo vermello

d. Por último, se o valor da cela é distinto de INSUFICIENTE, engadir un fondo verde