Contabilidade dunha biblioteca con Calc

Imaxinemos que desexamos ter unha folla de cálculo sinxela para comprobar o saldo da biblioteca do centro. Por exemplo a partir dun saldo existente no mes de setembro, a folla de cálculo irá descontando as compras que se vaian facendo. Algo así:

1. Descarga a folla de cálculo sen fórmulas e imos completándoas.

2. O primeiro que podemos completar é a columna de importe acumulado, é dicir, sumar todos os importes a medida que vaian chegando. Para isto, colocámonos na cela F7. Na primeira cela poderiamos introducir a fórmula "=E7". Sen embargo na seguinte, xa teriamos que mudar a fórmula e poñer algo así "=E8 + F7". Funcionaría.

Sen embargo ao arrastrar ata unha posición na que non existen datos na columna E, a folla de cálculo imprimiría o acumulado en celas que non nos interesa. E ademais, iso de poñer dúas fórmulas, unha en F7 e outra en F8..

Para arranxalo podemos engadir fórmulas con condicionais. O primeiro condicional é que non calcule o acumulado se ten algún número na cela da esquerda. E ademais, para non ter que meter dúas fórmulas, tamén comprobaremos se a cela anterior na columna F é un número. A fórmula podería ser a seguinte:

=SE(ÉNUMERO(E7);E7+(SE(ÉNUMERO(F6);F6;0));"")

E quedaría algo así:

 

 

Centrándonos na columna do saldo, o primeiro que faremos é seleccionar un conxunto amplo de celas e seguidamente pinchar en Formato > Condicional > Condición .

E escolleremos o estilo Good cando o saldo é superior a 0€ e o estilo Bad cando o saldo é inferior a 0€

E xa, estudando a fórmula a inserir...restaremos aos 1500€, o importe acumulado. Para arrastrar a fórmula, teremos que bloquear a cela do saldo G4, cun G$4. Tamén comprobaremos que a cela da esquerda en un número para evitar que aparezan datos na G18, G19, etc.

=SE(ÉNUMERO(F7);G$4-F7;"")

Arrastramos e obtemos o resultado final: