donkey-2761528_640.jpg

Para instalar amule empregamos a seguinte instrución desde root:

apt update

apt install amule

En aparencia o programa queda instalado correctamente, sen embargo obtemos o seguinte erro:

../src/unix/sockunix.cpp(143): assert "m_fd != INVALID_SOCKET" failed in OnReadWaiting(): invalid socket ready for reading?

erro amule.png

 

Sen desinstalar o amule, instala os seguintes paquetes:

apt install libupnp6 libupnp6-dev

Proba a arrancalo de novo. Se non funcionase novamente instala tamén os seguintes paquetes:

apt install libwxbase3.0-0 libwxbase3.0-dev libwxbase3.0-0-dbg libwxgtk3.0-0 libwxgtk3.0-dev
 
Volve a arrancar o programa e xa non aparecerá o erro e funcionará correctamente